<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
<title>New S-Class Has a Brabus Package Already - S500 Now Produces 500hp - GTspirit</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<script src="/cdn-cgi/apps/head/tzTzfk3zGwZodGn9_HyCWIjAwiE.js"></script><link rel="pingback" href="https://gtspirit.com/xmlrpc.php" />
<link rel="icon" type="image/png" href="https://gtspirit.com/wp-content/uploads/general/arrows-icon-150x150.png"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://gtspirit.com/wp-content/uploads/general/gtspirit-logo-square-76x.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://gtspirit.com/wp-content/uploads/general/gtspirit-logo-square-120.png" /><link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://gtspirit.com/wp-content/uploads/general/gtspirit-logo-square-152px.png" /><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://gtspirit.com/wp-content/uploads/general/gtspirit-logo-square-114.png" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://gtspirit.com/wp-content/uploads/general/gtspirit-logo-square-144.png" />

<meta name="description" content="Brabus has refined and upgraded the new Mercedes Benz S-Class, giving both the S500 4Matic and S400d a twist of exclusiveness." />
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large" />
<link rel="canonical" href="https://gtspirit.com/2021/04/19/new-s-class-has-a-brabus-package-already-s500-now-produces-500hp/" />
<meta property="og:locale" content="en_US">
<meta property="og:type" content="article">
<meta property="og:title" content="New S-Class Has a Brabus Package Already - S500 Now Produces 500hp - GTspirit">
<meta property="og:description" content="Brabus has refined and upgraded the new Mercedes Benz S-Class, giving both the S500 4Matic and S400d a twist of exclusiveness.">
<meta property="og:url" content="https://gtspirit.com/2021/04/19/new-s-class-has-a-brabus-package-already-s500-now-produces-500hp/">
<meta property="og:site_name" content="GTspirit">
<meta property="article:publisher" content="http://www.facebook.com/gtspirit">
<meta property="article:section" content="Car News">
<meta property="article:published_time" content="2021-04-19T15:48:16+02:00">
<meta property="og:image" content="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-hp-696x464.jpg">
<meta property="og:image:secure_url" content="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-hp-696x464.jpg">
<meta property="og:image:width" content="696">
<meta property="og:image:height" content="464">
<meta property="og:image:alt" content="Brabus S-Class hp">
<meta property="og:image:type" content="image/jpeg">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="New S-Class Has a Brabus Package Already - S500 Now Produces 500hp - GTspirit">
<meta name="twitter:description" content="Brabus has refined and upgraded the new Mercedes Benz S-Class, giving both the S500 4Matic and S400d a twist of exclusiveness.">
<meta name="twitter:site" content="@gtspirit">
<meta name="twitter:creator" content="@gtspirit">
<meta name="twitter:image" content="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-hp-696x464.jpg">
<script type="application/ld+json">{"@context":"https:\/\/schema.org","@graph":[{"@type":"Article","headline":"New S-Class Has a Brabus Package Already - S500 Now Produces 500hp - GTspirit","description":"Brabus has refined and upgraded the new Mercedes Benz S-Class, giving both the S500 4Matic and S400d a twist of exclusiveness.","datePublished":"2021-04-19T15:48:16+02:00","dateModified":"2021-04-19T15:48:16+02:00","publisher":{"@type":"Organization","name":"GTspirit Limited","logo":{"@type":"ImageObject","url":"https:\/\/gtspirit.com\/wp-content\/uploads\/2020\/06\/gtspirit-logo-square-android-500x500-1.png"}},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/gtspirit.com\/2021\/04\/19\/new-s-class-has-a-brabus-package-already-s500-now-produces-500hp\/"},"author":{"@type":"Person","name":"GTspirit Team"},"image":{"@type":"ImageObject","url":"https:\/\/gtspirit.com\/wp-content\/uploads\/2021\/04\/Brabus-S-Class-hp.jpg","width":2272,"height":1515}}]}</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="GTspirit &raquo; Feed" href="https://gtspirit.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GTspirit &raquo; Comments Feed" href="https://gtspirit.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="GTspirit &raquo; New S-Class Has a Brabus Package Already &#8211; S500 Now Produces 500hp Comments Feed" href="https://gtspirit.com/2021/04/19/new-s-class-has-a-brabus-package-already-s500-now-produces-500hp/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/gtspirit.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.5"}};
			/*! This file is auto-generated */
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://gtspirit.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='NextGEN-css' href='https://gtspirit.com/home/abc10995/public_html/wp-content/plugins/nextcellent-gallery-nextgen-legacy/css/nggallery.css?ver=1.0.0' type='text/css' media='screen' />
<link rel='stylesheet' id='NextCellent-Framework-css' href='https://gtspirit.com/wp-content/plugins/nextcellent-gallery-nextgen-legacy/css/framework-min.css?ver=1.0.1' type='text/css' media='screen' />
<link rel='stylesheet' id='dashicons-css' href='https://gtspirit.com/wp-includes/css/dashicons.min.css?ver=5.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css' href='https://gtspirit.com/wp-includes/js/thickbox/thickbox.css?ver=5.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css' href='https://gtspirit.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=28832a33217c23aa6f76cdf3fc3c1388' type='text/css' media='all' />
<style id="google-fonts-style-css" media="all">@font-face {
  font-family: 'Open Sans';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/opensans/v18/mem8YaGs126MiZpBA-UFVZ0e.ttf) format('truetype');
}
@font-face {
  font-family: 'Open Sans';
  font-style: normal;
  font-weight: 600;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/opensans/v18/mem5YaGs126MiZpBA-UNirkOUuhs.ttf) format('truetype');
}
@font-face {
  font-family: 'Open Sans';
  font-style: normal;
  font-weight: 700;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/opensans/v18/mem5YaGs126MiZpBA-UN7rgOUuhs.ttf) format('truetype');
}
@font-face {
  font-family: 'Roboto';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/roboto/v20/KFOmCnqEu92Fr1Mu4mxP.ttf) format('truetype');
}
@font-face {
  font-family: 'Roboto';
  font-style: normal;
  font-weight: 500;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/roboto/v20/KFOlCnqEu92Fr1MmEU9fBBc9.ttf) format('truetype');
}
@font-face {
  font-family: 'Roboto';
  font-style: normal;
  font-weight: 700;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/roboto/v20/KFOlCnqEu92Fr1MmWUlfBBc9.ttf) format('truetype');
}
</style>
<link rel='stylesheet' id='tablepress-default-css' href='https://gtspirit.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.11' type='text/css' media='all' />
<style id='tablepress-default-inline-css' type='text/css'>
.tablepress-id-22,.tablepress-id-22 td,.tablepress-id-22 th{border:none!important;border-collapse:collapse!important;border-spacing:0!important}.tablepress-id-22 .column-2{width:150px}.tablepress-id-23,.tablepress-id-23 td,.tablepress-id-23 th{border:none!important;border-collapse:collapse!important;border-spacing:0!important}.tablepress-id-23 .column-2{width:150px}.tablepress-id-24,.tablepress-id-24 td,.tablepress-id-24 th{border:none!important;border-collapse:collapse!important;border-spacing:0!important}.tablepress-id-24 .column-2{width:150px}
</style>
<link rel='stylesheet' id='td-theme-css' href='https://gtspirit.com/wp-content/themes/Newspaper/style.css?ver=10.3.4' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='td-legacy-framework-front-style-css' href='https://gtspirit.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=28832a33217c23aa6f76cdf3fc3c1388' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css' href='https://gtspirit.com/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=e06dc97a9cdcc3f12ae1599dfcd5b98f' type='text/css' media='all' />
<link rel='stylesheet' id='tdb_front_style-css' href='https://gtspirit.com/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=243b277d395aac11337949f2c0b8e89c' type='text/css' media='all' />
<script type='text/javascript' src='https://gtspirit.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://gtspirit.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://gtspirit.com/wp-content/plugins/nextcellent-gallery-nextgen-legacy/js/owl.carousel.min.js?ver=2'></script>
<link rel='https://api.w.org/' href='https://gtspirit.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://gtspirit.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://gtspirit.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://gtspirit.com/?p=252269' />
<link rel="alternate" type="application/json+oembed" href="https://gtspirit.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgtspirit.com%2F2021%2F04%2F19%2Fnew-s-class-has-a-brabus-package-already-s500-now-produces-500hp%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://gtspirit.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fgtspirit.com%2F2021%2F04%2F19%2Fnew-s-class-has-a-brabus-package-already-s500-now-produces-500hp%2F&#038;format=xml" />

<meta name="ahrefs-site-verification" content="b0bc89605111dcdae94a2a434c0d2166f9835da72b13062fe70db21ff9f3b92f">
<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
googletag.defineSlot('/4128695/2015-header', [728, 90], 'div-gpt-ad-1587655223160-0').setForceSafeFrame(true).addService(googletag.pubads());
googletag.defineSlot('/4128695/2020-mob-article-inline', [336, 320], 'div-gpt-ad-1587724152882-0').setForceSafeFrame(true).addService(googletag.pubads());
googletag.defineSlot('/4128695/2020-mobile-footer', [336, 320], 'div-gpt-ad-1587753699020-0').setForceSafeFrame(true).addService(googletag.pubads());
googletag.defineSlot('/4128695/2020-mobile-2', [336, 320], 'div-gpt-ad-1587753915714-0').setForceSafeFrame(true).addService(googletag.pubads());
googletag.defineSlot('/4128695/2015-ros-sidebar1', [300, 600], 'div-gpt-ad-1587715863902-0').setForceSafeFrame(true).addService(googletag.pubads());
googletag.defineSlot('/4128695/2015-ros-sidebar2', [300, 600], 'div-gpt-ad-1587716430373-0').setForceSafeFrame(true).addService(googletag.pubads());
googletag.defineSlot('/4128695/2015-ros-sidebar3', [300, 250], 'div-gpt-ad-1587716537923-0').setForceSafeFrame(true).addService(googletag.pubads());
googletag.defineSlot('/4128695/2015-feature-home', [[728, 90], [1068, 250], [980, 300], [1068, 300], [1, 1], [970, 250]], 'div-gpt-ad-1587655641594-0').setForceSafeFrame(true).addService(googletag.pubads());
googletag.defineSlot('/4128695/2015-article-bottom', [[696, 250], [696, 300], [640, 300], [336, 280], [300, 250], [640, 280], [696, 200]], 'div-gpt-ad-1587897006352-0').setForceSafeFrame(true).addService(googletag.pubads());
googletag.defineSlot('/4128695/2020-article-top', [[640, 300], [696, 300]], 'div-gpt-ad-1587897247673-0').setForceSafeFrame(true).addService(googletag.pubads());
googletag.defineSlot('/4128695/2015-article-inline', [[300, 250], [696, 300], [696, 250]], 'div-gpt-ad-1588190591496-0').setForceSafeFrame(true).addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>
<script type="text/javascript">
  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-233450-1']);
  _gaq.push(['_trackPageview']);
  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();
</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-9098340382139582",
          enable_page_level_ads: true
     });
</script>
<style>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</style>
<link id='MediaRSS' rel='alternate' type='application/rss+xml' title='NextGEN Gallery RSS Feed' href='https://gtspirit.com/wp-content/plugins/nextcellent-gallery-nextgen-legacy/xml/media-rss.php' />
<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<script>
        window.tdb_globals = {"wpRestNonce":"892b528b09","wpRestUrl":"https:\/\/gtspirit.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/gtspirit.com\/wp-admin\/","wpRestNonce":"892b528b09","wpRestUrl":"https:\/\/gtspirit.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/"};
			</script>

<script>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</script>

<style>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</style>
<script data-ad-client="ca-pub-9098340382139582" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://gtspirit.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://gtspirit.com/category/car-news/",
                    "name": "Car News"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://gtspirit.com/2021/04/19/new-s-class-has-a-brabus-package-already-s500-now-produces-500hp/",
                    "name": "New S-Class Has a Brabus Package Already &#8211; S500 Now Produces 500hp"                                
                }
            }    
        ]
    }
</script>
<link rel="icon" href="https://gtspirit.com/wp-content/uploads/2015/12/gtspirit-logo-square-android-500x500-150x150.png" sizes="32x32" />
<link rel="icon" href="https://gtspirit.com/wp-content/uploads/2015/12/gtspirit-logo-square-android-500x500-300x300.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://gtspirit.com/wp-content/uploads/2015/12/gtspirit-logo-square-android-500x500-300x300.png" />
<meta name="msapplication-TileImage" content="https://gtspirit.com/wp-content/uploads/2015/12/gtspirit-logo-square-android-500x500-300x300.png" />

<style>
    .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                    color: #dd0000;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #dd0000;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #dd0000;
                }
                .tdm-btn-style1 {
					background-color: #dd0000;
				}
				.tdm-btn-style2:before {
				    border-color: #dd0000;
				}
				.tdm-btn-style2 {
				    color: #dd0000;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #dd0000;
                    -moz-box-shadow: 0 2px 16px #dd0000;
                    box-shadow: 0 2px 16px #dd0000;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #dd0000;
                    -moz-box-shadow: 0 4px 26px #dd0000;
                    box-shadow: 0 4px 26px #dd0000;
				}
</style>
<style id="tdw-css-placeholder"></style></head>
<body class="post-template-default single single-post postid-252269 single-format-standard td-standard-pack new-s-class-has-a-brabus-package-already-s500-now-produces-500hp global-block-template-2 single_template_3 td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/gtspirit" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/gtspirit" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://gtspirit.com/rss/" title="RSS">
<i class="td-icon-font td-icon-rss"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.twitter.com/gtspirit" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.youtube.com/user/gtspiritlive" title="Youtube">
<i class="td-icon-font td-icon-youtube"></i>
</a>
</span> </div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-129272" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-first menu-item-129272"><a href="https://gtspirit.com/latest-articles/">Latest Articles<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-129276" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129276"><a href="https://gtspirit.com/latest-articles/">Classic View</a></li>
<li id="menu-item-130077" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-130077"><a href="https://gtspirit.com">GT Spirit</a></li>
<li id="menu-item-129273" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129273"><a href="https://gtspirit.com/blog/">Blog View</a></li>
<li id="menu-item-129274" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129274"><a href="https://gtspirit.com/widescreen/">Widescreen</a></li>
</ul>
</li>
<li id="menu-item-129277" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-129277"><a href="https://gtspirit.com/cars/">Cars<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-129278" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-129278"><a href="https://gtspirit.com/category/car-news/">Car News</a></li>
<li id="menu-item-129279" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-129279"><a href="https://gtspirit.com/category/car-news/for-sale/">Cars For Sale</a></li>
<li id="menu-item-131247" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-131247"><a href="https://gtspirit.com/cars/hypercars/">Hypercars</a></li>
<li id="menu-item-129280" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-129280"><a href="https://gtspirit.com/category/car-news/new-cars/">New Cars</a></li>
<li id="menu-item-129281" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-129281"><a href="https://gtspirit.com/category/car-news/road-tests/">Car Reviews</a></li>
</ul>
</li>
<li id="menu-item-129282" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129282"><a href="https://gtspirit.com/tuning/">Tuning</a></li>
<li id="menu-item-129287" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-129287"><a href="https://gtspirit.com/luxury/">Luxury<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-130450" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130450"><a href="https://gtspirit.com/category/lifestyle/hotels-resorts/hotel-openings/">Hotel Openings</a></li>
<li id="menu-item-130449" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130449"><a href="https://gtspirit.com/category/lifestyle/hotels-resorts/hotel-reviews/">Hotel Reviews</a></li>
<li id="menu-item-148766" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-148766"><a href="https://gtspirit.com/category/lifestyle/restaurant-reviews/">Restaurant Reviews</a></li>
<li id="menu-item-130486" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130486"><a href="https://gtspirit.com/category/lifestyle/superyachts/">Superyachts</a></li>
<li id="menu-item-131104" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131104"><a href="https://gtspirit.com/category/lifestyle/travel/">Travel Blog</a></li>
<li id="menu-item-130485" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130485"><a href="https://gtspirit.com/category/lifestyle/real-estate/villas-for-sale/">Villas For Sale</a></li>
</ul>
</li>
<li id="menu-item-129283" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129283"><a href="https://gtspirit.com/events/">Events</a></li>
<li id="menu-item-129286" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129286"><a href="https://gtspirit.com/motorsports/">Motorsport</a></li>
<li id="menu-item-129285" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-129285"><a href="https://gtspirit.com/reviews/">Reviews<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-129289" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-129289"><a href="https://gtspirit.com/category/car-news/road-tests/">Car Reviews</a></li>
<li id="menu-item-131270" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131270"><a href="https://gtspirit.com/category/hypercars/hypercar-reviews/">Hypercar Reviews</a></li>
<li id="menu-item-130448" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130448"><a href="https://gtspirit.com/category/tuning/tuning-reviews/">Tuning Reviews</a></li>
<li id="menu-item-129288" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-129288"><a href="https://gtspirit.com/category/lifestyle/hotels-resorts/hotel-reviews/">Hotel Reviews</a></li>
<li id="menu-item-148765" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-148765"><a href="https://gtspirit.com/category/lifestyle/restaurant-reviews/">Restaurant Reviews</a></li>
</ul>
</li>
</ul></div> </div>
</div>

<div id="login-form-mobile" class="td-register-section">
<div id="td-login-mob" class="td-login-animation td-login-hide-mob">

<div class="td-login-close">
<a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
<div class="td-login-title">Sign in</div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>
<div class="td-login-form-wrap">
<div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
<input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
<div class="td-login-info-text">
<a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
</div>
<div class="td-login-register-link">
</div>
<div class="td-login-info-text"><a class="privacy-policy-link" href="https://gtspirit.com/privacy-policy/">Privacy Policy</a></div>
</div>
</div>
<div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">

<div class="td-forgot-pass-close">
<a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
<div class="td-login-title">Password recovery</div>
</div>
<div class="td-login-form-wrap">
<div class="td-login-panel-title">Recover your password</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
<input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
</div>
</div>
</div>
</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search">
<form method="get" class="td-search-form" action="https://gtspirit.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
</div>
</div>
<div id="td-outer-wrap" class="td-theme-wrap">
<div class="tdc-header-wrap ">

<div class="td-header-wrap td-header-style-5 ">
<div class="td-header-top-menu-full td-container-wrap ">
<div class="td-container td-header-row td-header-top-menu">
<div class="top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="menu-top-container"><ul id="menu-top-navigation" class="top-header-menu"><li id="menu-item-60767" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-60767"><a href="https://gtspirit.com/">GTspirit Home</a></li>
<li id="menu-item-204699" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-204699"><a href="https://www.gtspirit.de">GTspirit.de</a></li>
<li id="menu-item-60768" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-60768"><a href="https://gtspirit.com/about-gtspirit/">About GTspirit</a></li>
<li id="menu-item-116895" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-116895"><a href="https://www.gtspiritmedia.com">GTspirit Media</a></li>
<li id="menu-item-158910" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-158910"><a href="https://www.gtspirittour.com/">GTspirit Tour</a></li>
<li id="menu-item-61652" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-61652"><a href="https://gtspirit.com/owners-club/">Owners Club</a></li>
<li id="menu-item-60770" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-60770"><a href="https://gtspirit.com/advertise/">Advertise</a></li>
<li id="menu-item-60793" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-60793"><a href="https://gtspirit.com/tips/">Tip us</a></li>
<li id="menu-item-60771" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-60771"><a href="https://gtspirit.com/contact/">Contact</a></li>
</ul></div></div>
<div class="td-header-sp-top-widget">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/gtspirit" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/gtspirit" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://gtspirit.com/rss/" title="RSS">
<i class="td-icon-font td-icon-rss"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.twitter.com/gtspirit" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.youtube.com/user/gtspiritlive" title="Youtube">
<i class="td-icon-font td-icon-youtube"></i>
</a>
</span> </div> </div>

<div id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
<div class="td-login-wrap">
<a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
<div id="td-login-div" class="td-login-form-div td-display-block">
<div class="td-login-panel-title">Sign in</div>
<div class="td-login-panel-descr">Welcome! Log into your account</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
<input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
<div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
<div class="td-login-info-text"><a class="privacy-policy-link" href="https://gtspirit.com/privacy-policy/">Privacy Policy</a></div>
</div>
<div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
<div class="td-login-panel-title">Password recovery</div>
<div class="td-login-panel-descr">Recover your password</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
<input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
<div class="td-login-info-text">A password will be e-mailed to you.</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-header-menu-wrap-full td-container-wrap ">
<div class="td-header-menu-wrap ">
<div class="td-container td-header-row td-header-main-menu black-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-menu">
<a class="td-mobile-logo td-sticky-header" href="https://gtspirit.com/">
<img class="td-retina-data" data-retina="https://gtspirit.com/wp-content/uploads/general/gtspirit-logo.png" src="https://gtspirit.com/wp-content/uploads/general/gtspirit-logo.png" alt="GTspirit" title="GTspirit" />
</a>
<a class="td-header-logo td-sticky-header" href="https://gtspirit.com/">
<img class="td-retina-data" data-retina="https://gtspirit.com/wp-content/uploads/general/gtspirit-logo.png" src="https://gtspirit.com/wp-content/uploads/general/gtspirit-logo.png" alt="GTspirit" title="GTspirit" />
<span class="td-visual-hidden">GTspirit</span>
</a>
</div>
<div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-first td-menu-item td-normal-menu menu-item-129272"><a href="https://gtspirit.com/latest-articles/">Latest Articles</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-129276"><a href="https://gtspirit.com/latest-articles/">Classic View</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home td-menu-item td-normal-menu menu-item-130077"><a href="https://gtspirit.com">GT Spirit</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-129273"><a href="https://gtspirit.com/blog/">Blog View</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-129274"><a href="https://gtspirit.com/widescreen/">Widescreen</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-129277"><a href="https://gtspirit.com/cars/">Cars</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-129278"><a href="https://gtspirit.com/category/car-news/">Car News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-129279"><a href="https://gtspirit.com/category/car-news/for-sale/">Cars For Sale</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-131247"><a href="https://gtspirit.com/cars/hypercars/">Hypercars</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-129280"><a href="https://gtspirit.com/category/car-news/new-cars/">New Cars</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-129281"><a href="https://gtspirit.com/category/car-news/road-tests/">Car Reviews</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-129282"><a href="https://gtspirit.com/tuning/">Tuning</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-129287"><a href="https://gtspirit.com/luxury/">Luxury</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-130450"><a href="https://gtspirit.com/category/lifestyle/hotels-resorts/hotel-openings/">Hotel Openings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-130449"><a href="https://gtspirit.com/category/lifestyle/hotels-resorts/hotel-reviews/">Hotel Reviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-148766"><a href="https://gtspirit.com/category/lifestyle/restaurant-reviews/">Restaurant Reviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-130486"><a href="https://gtspirit.com/category/lifestyle/superyachts/">Superyachts</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-131104"><a href="https://gtspirit.com/category/lifestyle/travel/">Travel Blog</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-130485"><a href="https://gtspirit.com/category/lifestyle/real-estate/villas-for-sale/">Villas For Sale</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-129283"><a href="https://gtspirit.com/events/">Events</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-129286"><a href="https://gtspirit.com/motorsports/">Motorsport</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-129285"><a href="https://gtspirit.com/reviews/">Reviews</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-129289"><a href="https://gtspirit.com/category/car-news/road-tests/">Car Reviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-131270"><a href="https://gtspirit.com/category/hypercars/hypercar-reviews/">Hypercar Reviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-130448"><a href="https://gtspirit.com/category/tuning/tuning-reviews/">Tuning Reviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-129288"><a href="https://gtspirit.com/category/lifestyle/hotels-resorts/hotel-reviews/">Hotel Reviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-148765"><a href="https://gtspirit.com/category/lifestyle/restaurant-reviews/">Restaurant Reviews</a></li>
</ul>
</li>
</ul></div></div>
<div class="header-search-wrap">
<div class="td-search-btns-wrap">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://gtspirit.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div>
</div>
</div>
<div class="td-header-header-full td-banner-wrap-full td-container-wrap ">
<div class="td-container-header td-header-row td-header-header">
<div class="td-header-sp-recs">
<div class="td-header-rec-wrap">
<div class="td-a-rec td-a-rec-id-header  td-rec-hide-on-p tdi_1_7c9 td_block_template_2">
<style>
/* custom css */
.tdi_1_7c9.td-a-rec{
					text-align: center;
				}.tdi_1_7c9 .td-element-style{
					z-index: -1;
				}.tdi_1_7c9.td-a-rec-img{
				    text-align: left;
				}.tdi_1_7c9.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_1_7c9.td-a-rec-img {
				        text-align: center;
				    }
                }
</style>
<div id='div-gpt-ad-1587655223160-0' style='width: 728px; height: 90px;'>
<script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1587655223160-0'); });
  </script>
</div></div>
</div> </div>
</div>
</div>
</div>
</div>
<article id="post-252269" class="td-post-template-3 post-252269 post type-post status-publish format-standard has-post-thumbnail category-car-news category-brabus category-mercedes td-container-wrap" itemscope itemtype="https://schema.org/Article">
<div class="td-post-header td-container">
<div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://gtspirit.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Car News" class="entry-crumb" href="https://gtspirit.com/category/car-news/">Car News</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">New S-Class Has a Brabus Package Already &#8211; S500 Now Produces 500hp</span></div></div>
<div class="td-post-header-holder td-image-gradient">
<div class="td-post-featured-image"><a href="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-hp.jpg" data-caption=""><img width="1068" height="712" class="entry-thumb td-modal-image" src="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-hp-1068x712.jpg" srcset="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-hp-1068x712.jpg 1068w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-hp-300x200.jpg 300w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-hp-696x464.jpg 696w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-hp-768x512.jpg 768w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-hp-1536x1024.jpg 1536w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-hp-2048x1366.jpg 2048w" sizes="(max-width: 1068px) 100vw, 1068px" alt="Brabus S-Class hp" title="Brabus S-Class hp" /></a></div>
<header class="td-post-title">
<h1 class="entry-title">New S-Class Has a Brabus Package Already &#8211; S500 Now Produces 500hp</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://gtspirit.com/author/mr/">GTspirit Team</a><div class="td-author-line"> - </div> </div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-19T15:48:16+02:00">19th April 2021</time></span> </div>
</header>
</div>
</div>
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<div class="td-post-content tagdiv-type">
<p>Brabus has refined and upgraded the new Mercedes Benz S-Class, giving both the S500 4Matic and S400d a twist of exclusiveness.</p>
<p>The first step of the upgrade was installing the plug-and-play Brabus B50- 500 PowerXtra performance module on the S 500 4MATIC gasoline engine, the module pumps up the powerplant by 65hp and increases the torque by adding 70Nm of torque. </p>
<p>After the modification, the official output of the new Mercedes S-Class has been increased from 435hp to 500hp horsepower, torque has been improved from 520Nm to 590Nm and is available from 1,800rpm and 5,800rpm. The acceleration from 0-100km/h is now achieved in 4.7 seconds. The top speed remains electronically limited to 250km/h.</p>
<p><a href="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Full-Black.jpg"><img src="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Full-Black-696x464.jpg" alt="Brabus S-Class Full Black" width="696" height="464" class="alignnone size-large wp-image-252278" srcset="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Full-Black-696x464.jpg 696w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Full-Black-300x200.jpg 300w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Full-Black-768x512.jpg 768w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Full-Black-1536x1024.jpg 1536w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Full-Black-2048x1366.jpg 2048w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Full-Black-1068x712.jpg 1068w" sizes="(max-width: 696px) 100vw, 696px" /></a></p>
<p>A Brabus PowerXtra D40 performance kit module will also be available for the Mercedes S 400 D 4MATIC and it will boost the output of the diesel engine by 40hp and increase the torque by 50Nm. After installing the module, the engine of the car will have an output of 370hp and 750Nm peak torque at a low 2,500 rpm. Top speed will be 250km/h and the acceleration from 0-100km/h will be achieved in just 5.2 seconds.</p>
<p>The exterior of the vehicle features a Brabus front spoiler that reduces front axle lift to boot, side air intakes with surrounds, integrated LED side markers and a sporting styled insert at the rear bumper. A naked carbon rear spoiler lip will also be available soon.</p>
<p>The interior of the new S-Class includes a range of options from an eight-piece scuff plate set with Brabus logos which can light up in white or change color to match the ambient lighting. There is a two-tone soft and breathable Brabus fine leather on the dashboard and center console, carbon elements on the dashboard and center console and exclusive Brabus signature carbon trim sets specifically designed and developed for the S-Class.</p>
<p>The S 500 4MATIC can be fitted with Brabus signature Monoblock alloy wheels with diameters of 19, 20 and 21 inches all designed for the S-Class. A ‘Platinum Edition’ Forged Brabus alloys will also be available as exclusive wheel/tire combination and in various designs.</p>
<p>The S-Class pictured is fitted with the Platinum Edition wheels in size 9Jx21 on the front axle and 10.5Jx21 on the rear axle. The wheels are manufactured through high-tech forging technology and have been combined with large optimal tires in size 265/35 ZR 21 at the front and 305/30 ZR21 at the rear. </p>
<p>The sporty Brabus suspension improves the agility and handling of the vehicle as well as lowering the ride height by 25 millimeters depending on the drive mode selected.</p>
<style type="text/css">
                    
                    #tdi_2_08c  .td-doubleSlider-2 .td-item1 {
                        background: url(https://gtspirit.com/wp-content/uploads/2021/04/2021-Brabus-S-Class-80x60.jpg) 0 0 no-repeat;
                    }
                    #tdi_2_08c  .td-doubleSlider-2 .td-item2 {
                        background: url(https://gtspirit.com/wp-content/uploads/2021/04/2021-Brabus-S-Class-rear-80x60.jpg) 0 0 no-repeat;
                    }
                    #tdi_2_08c  .td-doubleSlider-2 .td-item3 {
                        background: url(https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-interior-screen-80x60.jpg) 0 0 no-repeat;
                    }
                    #tdi_2_08c  .td-doubleSlider-2 .td-item4 {
                        background: url(https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-0-100-80x60.jpg) 0 0 no-repeat;
                    }
                    #tdi_2_08c  .td-doubleSlider-2 .td-item5 {
                        background: url(https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-beige-interior-80x60.jpg) 0 0 no-repeat;
                    }
                    #tdi_2_08c  .td-doubleSlider-2 .td-item6 {
                        background: url(https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Black-80x60.jpg) 0 0 no-repeat;
                    }
                    #tdi_2_08c  .td-doubleSlider-2 .td-item7 {
                        background: url(https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-front-grille-80x60.jpg) 0 0 no-repeat;
                    }
                    #tdi_2_08c  .td-doubleSlider-2 .td-item8 {
                        background: url(https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-front-80x60.jpg) 0 0 no-repeat;
                    }
                    #tdi_2_08c  .td-doubleSlider-2 .td-item9 {
                        background: url(https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Full-Black-80x60.jpg) 0 0 no-repeat;
                    }
                    #tdi_2_08c  .td-doubleSlider-2 .td-item10 {
                        background: url(https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-hp-80x60.jpg) 0 0 no-repeat;
                    }
                    #tdi_2_08c  .td-doubleSlider-2 .td-item11 {
                        background: url(https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-interior-80x60.jpg) 0 0 no-repeat;
                    }
                    #tdi_2_08c  .td-doubleSlider-2 .td-item12 {
                        background: url(https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-price-80x60.jpg) 0 0 no-repeat;
                    }
                    #tdi_2_08c  .td-doubleSlider-2 .td-item13 {
                        background: url(https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-rear-seats-80x60.jpg) 0 0 no-repeat;
                    }
                    #tdi_2_08c  .td-doubleSlider-2 .td-item14 {
                        background: url(https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-rear-80x60.jpg) 0 0 no-repeat;
                    }
                    #tdi_2_08c  .td-doubleSlider-2 .td-item15 {
                        background: url(https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-side-80x60.jpg) 0 0 no-repeat;
                    }
                    #tdi_2_08c  .td-doubleSlider-2 .td-item16 {
                        background: url(https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-specs-80x60.jpg) 0 0 no-repeat;
                    }
                    #tdi_2_08c  .td-doubleSlider-2 .td-item17 {
                        background: url(https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-wheels-80x60.jpg) 0 0 no-repeat;
                    }
                    #tdi_2_08c  .td-doubleSlider-2 .td-item18 {
                        background: url(https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-80x60.jpg) 0 0 no-repeat;
                    }
                </style>
<div id="tdi_2_08c" class="td-gallery td-slide-on-2-columns">
<div class="post_td_gallery">
<div class="td-gallery-slide-top">
<div class="td-gallery-title">2021 Brabus S-Class</div>
<div class="td-gallery-controls-wrapper">
<div class="td-gallery-slide-count"><span class="td-gallery-slide-item-focus">1</span> of 18</div>
<div class="td-gallery-slide-prev-next-but">
<i class="td-icon-left doubleSliderPrevButton"></i>
<i class="td-icon-right doubleSliderNextButton"></i>
</div>
</div>
</div>
<div class="td-doubleSlider-1 ">
 <div class="td-slider">
<div class="td-slide-item td-item1">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://gtspirit.com/wp-content/uploads/2021/04/2021-Brabus-S-Class.jpg" title="2021 Brabus S-Class" data-caption="" data-description="">
<img src="https://gtspirit.com/wp-content/uploads/2021/04/2021-Brabus-S-Class.jpg" srcset="https://gtspirit.com/wp-content/uploads/2021/04/2021-Brabus-S-Class.jpg 2272w, https://gtspirit.com/wp-content/uploads/2021/04/2021-Brabus-S-Class-300x212.jpg 300w, https://gtspirit.com/wp-content/uploads/2021/04/2021-Brabus-S-Class-696x493.jpg 696w, https://gtspirit.com/wp-content/uploads/2021/04/2021-Brabus-S-Class-768x544.jpg 768w, https://gtspirit.com/wp-content/uploads/2021/04/2021-Brabus-S-Class-1536x1088.jpg 1536w, https://gtspirit.com/wp-content/uploads/2021/04/2021-Brabus-S-Class-2048x1450.jpg 2048w, https://gtspirit.com/wp-content/uploads/2021/04/2021-Brabus-S-Class-1068x756.jpg 1068w, https://gtspirit.com/wp-content/uploads/2021/04/2021-Brabus-S-Class-100x70.jpg 100w" sizes="(max-width: 2272px) 100vw, 2272px" alt="2021 Brabus S-Class">
</a>
</figure>
</div>
<div class="td-slide-item td-item2">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://gtspirit.com/wp-content/uploads/2021/04/2021-Brabus-S-Class-rear.jpg" title="2021 Brabus S-Class rear" data-caption="" data-description="">
<img src="https://gtspirit.com/wp-content/uploads/2021/04/2021-Brabus-S-Class-rear.jpg" srcset="https://gtspirit.com/wp-content/uploads/2021/04/2021-Brabus-S-Class-rear.jpg 2272w, https://gtspirit.com/wp-content/uploads/2021/04/2021-Brabus-S-Class-rear-300x200.jpg 300w, https://gtspirit.com/wp-content/uploads/2021/04/2021-Brabus-S-Class-rear-696x464.jpg 696w, https://gtspirit.com/wp-content/uploads/2021/04/2021-Brabus-S-Class-rear-768x512.jpg 768w, https://gtspirit.com/wp-content/uploads/2021/04/2021-Brabus-S-Class-rear-1536x1024.jpg 1536w, https://gtspirit.com/wp-content/uploads/2021/04/2021-Brabus-S-Class-rear-2048x1366.jpg 2048w, https://gtspirit.com/wp-content/uploads/2021/04/2021-Brabus-S-Class-rear-1068x712.jpg 1068w" sizes="(max-width: 2272px) 100vw, 2272px" alt="2021 Brabus S-Class rear">
</a>
</figure>
</div>
<div class="td-slide-item td-item3">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-interior-screen.jpg" title="Brabus S Class interior screen" data-caption="" data-description="">
<img src="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-interior-screen.jpg" srcset="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-interior-screen.jpg 2272w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-interior-screen-300x200.jpg 300w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-interior-screen-696x464.jpg 696w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-interior-screen-768x512.jpg 768w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-interior-screen-1536x1024.jpg 1536w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-interior-screen-2048x1366.jpg 2048w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-interior-screen-1068x712.jpg 1068w" sizes="(max-width: 2272px) 100vw, 2272px" alt="Brabus S Class interior screen">
</a>

</figure>
</div>
<div class="td-slide-item td-item4">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-0-100.jpg" title="Brabus S-Class 0-100" data-caption="" data-description="">
<img src="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-0-100.jpg" srcset="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-0-100.jpg 2272w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-0-100-300x200.jpg 300w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-0-100-696x464.jpg 696w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-0-100-768x512.jpg 768w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-0-100-1536x1024.jpg 1536w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-0-100-2048x1366.jpg 2048w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-0-100-1068x712.jpg 1068w" sizes="(max-width: 2272px) 100vw, 2272px" alt="Brabus S-Class 0-100">
</a>
</figure>
</div>
<div class="td-slide-item td-item5">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-beige-interior.jpg" title="Brabus S-Class beige interior" data-caption="" data-description="">
<img src="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-beige-interior.jpg" srcset="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-beige-interior.jpg 2272w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-beige-interior-300x200.jpg 300w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-beige-interior-696x464.jpg 696w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-beige-interior-768x512.jpg 768w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-beige-interior-1536x1024.jpg 1536w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-beige-interior-2048x1366.jpg 2048w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-beige-interior-1068x712.jpg 1068w" sizes="(max-width: 2272px) 100vw, 2272px" alt="Brabus S-Class beige interior">
</a>
</figure>
</div>
<div class="td-slide-item td-item6">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Black.jpg" title="Brabus S-Class Black" data-caption="" data-description="">
<img src="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Black.jpg" srcset="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Black.jpg 2272w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Black-300x200.jpg 300w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Black-696x464.jpg 696w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Black-768x512.jpg 768w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Black-1536x1024.jpg 1536w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Black-2048x1366.jpg 2048w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Black-1068x712.jpg 1068w" sizes="(max-width: 2272px) 100vw, 2272px" alt="Brabus S-Class Black">
</a>
</figure>
</div>
<div class="td-slide-item td-item7">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-front-grille.jpg" title="Brabus S-Class front grille" data-caption="" data-description="">
<img src="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-front-grille.jpg" srcset="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-front-grille.jpg 2272w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-front-grille-300x200.jpg 300w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-front-grille-696x464.jpg 696w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-front-grille-768x512.jpg 768w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-front-grille-1536x1024.jpg 1536w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-front-grille-2048x1366.jpg 2048w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-front-grille-1068x712.jpg 1068w" sizes="(max-width: 2272px) 100vw, 2272px" alt="Brabus S-Class front grille">
</a>
</figure>
</div>
<div class="td-slide-item td-item8">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-front.jpg" title="Brabus S-Class front" data-caption="" data-description="">
<img src="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-front.jpg" srcset="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-front.jpg 2272w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-front-300x200.jpg 300w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-front-696x464.jpg 696w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-front-768x512.jpg 768w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-front-1536x1024.jpg 1536w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-front-2048x1366.jpg 2048w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-front-1068x712.jpg 1068w" sizes="(max-width: 2272px) 100vw, 2272px" alt="Brabus S-Class front">
</a>
</figure>
</div>
<div class="td-slide-item td-item9">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Full-Black.jpg" title="Brabus S-Class Full Black" data-caption="" data-description="">
<img src="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Full-Black.jpg" srcset="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Full-Black.jpg 2272w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Full-Black-300x200.jpg 300w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Full-Black-696x464.jpg 696w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Full-Black-768x512.jpg 768w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Full-Black-1536x1024.jpg 1536w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Full-Black-2048x1366.jpg 2048w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-Full-Black-1068x712.jpg 1068w" sizes="(max-width: 2272px) 100vw, 2272px" alt="Brabus S-Class Full Black">
</a>
</figure>
</div>
<div class="td-slide-item td-item10">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-hp.jpg" title="Brabus S-Class hp" data-caption="" data-description="">
<img src="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-hp.jpg" srcset="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-hp.jpg 2272w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-hp-300x200.jpg 300w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-hp-696x464.jpg 696w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-hp-768x512.jpg 768w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-hp-1536x1024.jpg 1536w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-hp-2048x1366.jpg 2048w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-hp-1068x712.jpg 1068w" sizes="(max-width: 2272px) 100vw, 2272px" alt="Brabus S-Class hp">
</a>
</figure>
</div>
<div class="td-slide-item td-item11">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-interior.jpg" title="Brabus S-Class interior" data-caption="" data-description="">
<img src="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-interior.jpg" srcset="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-interior.jpg 2272w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-interior-300x200.jpg 300w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-interior-696x464.jpg 696w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-interior-768x512.jpg 768w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-interior-1536x1024.jpg 1536w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-interior-2048x1366.jpg 2048w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-interior-1068x712.jpg 1068w" sizes="(max-width: 2272px) 100vw, 2272px" alt="Brabus S-Class interior">
</a>
</figure>
</div>
<div class="td-slide-item td-item12">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-price.jpg" title="Brabus S-Class price" data-caption="" data-description="">
<img src="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-price.jpg" srcset="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-price.jpg 2272w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-price-300x200.jpg 300w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-price-696x464.jpg 696w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-price-768x512.jpg 768w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-price-1536x1024.jpg 1536w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-price-2048x1366.jpg 2048w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-price-1068x712.jpg 1068w" sizes="(max-width: 2272px) 100vw, 2272px" alt="Brabus S-Class price">
</a>
</figure>
</div>
<div class="td-slide-item td-item13">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-rear-seats.jpg" title="Brabus S-Class rear seats" data-caption="" data-description="">
<img src="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-rear-seats.jpg" srcset="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-rear-seats.jpg 2272w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-rear-seats-300x200.jpg 300w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-rear-seats-696x464.jpg 696w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-rear-seats-768x512.jpg 768w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-rear-seats-1536x1024.jpg 1536w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-rear-seats-2048x1366.jpg 2048w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-rear-seats-1068x712.jpg 1068w" sizes="(max-width: 2272px) 100vw, 2272px" alt="Brabus S-Class rear seats">
</a>
</figure>
</div>
<div class="td-slide-item td-item14">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-rear.jpg" title="Brabus S-Class rear" data-caption="" data-description="">
<img src="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-rear.jpg" srcset="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-rear.jpg 2272w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-rear-300x200.jpg 300w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-rear-696x464.jpg 696w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-rear-768x512.jpg 768w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-rear-1536x1024.jpg 1536w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-rear-2048x1366.jpg 2048w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-rear-1068x712.jpg 1068w" sizes="(max-width: 2272px) 100vw, 2272px" alt="Brabus S-Class rear">
</a>
</figure>
</div>
<div class="td-slide-item td-item15">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-side.jpg" title="Brabus S-Class side" data-caption="" data-description="">
<img src="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-side.jpg" srcset="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-side.jpg 2272w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-side-300x200.jpg 300w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-side-696x464.jpg 696w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-side-768x512.jpg 768w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-side-1536x1024.jpg 1536w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-side-2048x1366.jpg 2048w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-side-1068x712.jpg 1068w" sizes="(max-width: 2272px) 100vw, 2272px" alt="Brabus S-Class side">
</a>
</figure>
</div>
<div class="td-slide-item td-item16">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-specs.jpg" title="Brabus S-Class specs" data-caption="" data-description="">
<img src="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-specs.jpg" srcset="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-specs.jpg 2272w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-specs-300x200.jpg 300w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-specs-696x464.jpg 696w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-specs-768x512.jpg 768w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-specs-1536x1024.jpg 1536w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-specs-2048x1366.jpg 2048w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-specs-1068x712.jpg 1068w" sizes="(max-width: 2272px) 100vw, 2272px" alt="Brabus S-Class specs">
</a>
</figure>
</div>
<div class="td-slide-item td-item17">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-wheels.jpg" title="Brabus S-Class wheels" data-caption="" data-description="">
<img src="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-wheels.jpg" srcset="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-wheels.jpg 2272w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-wheels-300x200.jpg 300w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-wheels-696x464.jpg 696w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-wheels-768x512.jpg 768w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-wheels-1536x1024.jpg 1536w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-wheels-2048x1366.jpg 2048w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-wheels-1068x712.jpg 1068w" sizes="(max-width: 2272px) 100vw, 2272px" alt="Brabus S-Class wheels">
</a>
</figure>
</div>
<div class="td-slide-item td-item18">
<figure class="td-slide-galery-figure td-slide-popup-gallery">
<a class="slide-gallery-image-link" href="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class.jpg" title="Brabus S-Class" data-caption="" data-description="">
<img src="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class.jpg" srcset="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class.jpg 2272w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-300x200.jpg 300w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-696x464.jpg 696w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-768x512.jpg 768w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-1536x1024.jpg 1536w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-2048x1366.jpg 2048w, https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-1068x712.jpg 1068w" sizes="(max-width: 2272px) 100vw, 2272px" alt="Brabus S-Class">
</a>
</figure>
</div>
</div>
</div>
<div class="td-doubleSlider-2">
<div class="td-slider">
<div class="td-button td-item1">
<div class="td-border"></div>
</div>
<div class="td-button td-item2">
<div class="td-border"></div>
</div>
<div class="td-button td-item3">
<div class="td-border"></div>
</div>
<div class="td-button td-item4">
<div class="td-border"></div>
</div>
 <div class="td-button td-item5">
<div class="td-border"></div>
</div>
<div class="td-button td-item6">
<div class="td-border"></div>
</div>
<div class="td-button td-item7">
<div class="td-border"></div>
</div>
<div class="td-button td-item8">
<div class="td-border"></div>
</div>
<div class="td-button td-item9">
<div class="td-border"></div>
</div>
<div class="td-button td-item10">
<div class="td-border"></div>
</div>
<div class="td-button td-item11">
<div class="td-border"></div>
</div>
<div class="td-button td-item12">
<div class="td-border"></div>
</div>
<div class="td-button td-item13">
<div class="td-border"></div>
</div>
<div class="td-button td-item14">
<div class="td-border"></div>
</div>
<div class="td-button td-item15">
<div class="td-border"></div>
</div>
<div class="td-button td-item16">
<div class="td-border"></div>
</div>
<div class="td-button td-item17">
<div class="td-border"></div>
</div>
<div class="td-button td-item18">
<div class="td-border"></div>
</div>
</div>
</div>
</div>
</div>
<div class="td-a-rec td-a-rec-id-content_bottom  tdi_3_699 td_block_template_2">
<style>
/* custom css */
.tdi_3_699.td-a-rec{
					text-align: center;
				}.tdi_3_699 .td-element-style{
					z-index: -1;
				}.tdi_3_699.td-a-rec-img{
				    text-align: left;
				}.tdi_3_699.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_3_699.td-a-rec-img {
				        text-align: center;
				    }
                }
</style>
<div id='div-gpt-ad-1587897006352-0'>
<script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1587897006352-0'); });
  </script>
</div></div> </div>
<footer>
<div class="td-post-source-tags">
</div>
<div class="td-post-sharing-bottom"><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
<div class="td-social-but-icon"><i class="td-icon-share"></i></div>
<div class="td-social-but-text">Share</div>
</div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fgtspirit.com%2F2021%2F04%2F19%2Fnew-s-class-has-a-brabus-package-already-s500-now-produces-500hp%2F">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=New+S-Class+Has+a+Brabus+Package+Already+%E2%80%93+S500+Now+Produces+500hp&url=https%3A%2F%2Fgtspirit.com%2F2021%2F04%2F19%2Fnew-s-class-has-a-brabus-package-already-s500-now-produces-500hp%2F&via=gtspirit">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=New+S-Class+Has+a+Brabus+Package+Already+%E2%80%93+S500+Now+Produces+500hp %0A%0A https://gtspirit.com/2021/04/19/new-s-class-has-a-brabus-package-already-s500-now-produces-500hp/">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://gtspirit.com/2021/04/19/new-s-class-has-a-brabus-package-already-s500-now-produces-500hp/&title=New+S-Class+Has+a+Brabus+Package+Already+%E2%80%93+S500+Now+Produces+500hp">
<div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div>
<div class="td-social-but-text">Linkedin</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#526d212730383731266f1c372572017f113e332121721a3321723372102033302721720233313933353772133e203733362b7274716a606363697201676262721c3d257202203d3627313721726762623a2274303d362b6f3a26262221687d7d352621223b203b267c313d3f7d606260637d62667d636b7d3c37257f217f313e3321217f3a33217f337f3020333027217f223331393335377f333e203733362b7f216762627f3c3d257f22203d36273137217f6762623a227d">
<div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
<div class="td-social-but-text">Email</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div> <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://gtspirit.com/2021/04/17/audi-q4-e-tron-and-q4-sportback-e-tron-full-electric-suvs-join-e-tron-family/">Audi Q4 e-tron and Q4 Sportback e-tron: Full Electric SUVs Join e-tron Family</a></div></div><div class="td-next-prev-separator"></div></div> <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://gtspirit.com/author/mr/">GTspirit Team</a></span></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="GTspirit Team"></span><meta itemprop="datePublished" content="2021-04-19T15:48:16+02:00"><meta itemprop="dateModified" content="2021-04-19T15:48:16+02:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://gtspirit.com/2021/04/19/new-s-class-has-a-brabus-package-already-s500-now-produces-500hp/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://gtspirit.com/wp-content/uploads/general/gtspirit-logo.png"></span><meta itemprop="name" content="GTspirit"></span><meta itemprop="headline " content="New S-Class Has a Brabus Package Already - S500 Now Produces 500hp"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-hp.jpg"><meta itemprop="width" content="2272"><meta itemprop="height" content="1515"></span> </footer>
<div class="td_block_wrap td_block_related_posts tdi_4_8dc td_with_ajax_pagination td-pb-border-top td_block_template_2" data-td-block-uid="tdi_4_8dc"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_tdi_4_8dc = new tdBlock();
block_tdi_4_8dc.id = "tdi_4_8dc";
block_tdi_4_8dc.atts = '{"limit":6,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_4_8dc","td_column_number":3,"live_filter_cur_post_id":252269,"live_filter_cur_post_author":"111","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_4_8dc","tdc_css_class_style":"tdi_4_8dc_rand_style"}';
block_tdi_4_8dc.td_column_number = "3";
block_tdi_4_8dc.block_type = "td_block_related_posts";
block_tdi_4_8dc.post_count = "6";
block_tdi_4_8dc.found_posts = "21406";
block_tdi_4_8dc.header_color = "";
block_tdi_4_8dc.ajax_pagination_infinite_stop = "";
block_tdi_4_8dc.max_num_pages = "3568";
tdBlocksArray.push(block_tdi_4_8dc);
</script><h4 class="td-related-title td-block-title"><a id="tdi_5_a06" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_4_8dc" href="#">You may also like</a><a id="tdi_6_990" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_4_8dc" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_4_8dc class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://gtspirit.com/2021/04/16/2022-mercedes-benz-eqs-is-here-750hp-version-announced-too/" rel="bookmark" class="td-image-wrap " title="2022 Mercedes-Benz EQS is Here, 750hp Version Announced Too"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Mercedes EQS 580 4Matic" title="2022 Mercedes-Benz EQS is Here, 750hp Version Announced Too" data-type="image_tag" data-img-url="https://gtspirit.com/wp-content/uploads/2021/04/20C0714_074-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://gtspirit.com/2021/04/16/2022-mercedes-benz-eqs-is-here-750hp-version-announced-too/" rel="bookmark" title="2022 Mercedes-Benz EQS is Here, 750hp Version Announced Too">2022 Mercedes-Benz EQS is Here, 750hp Version Announced Too</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://gtspirit.com/2021/04/14/mclaren-artura-official-performance-figures-0-100km-h-%c2%bc-mile-top-speed/" rel="bookmark" class="td-image-wrap " title="McLaren Artura Performance Figures [0-100km/h, ¼ mile, Top Speed]"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="McLaren Artura price" title="McLaren Artura Performance Figures [0-100km/h, ¼ mile, Top Speed]" data-type="image_tag" data-img-url="https://gtspirit.com/wp-content/uploads/2021/04/McLaren-Artura-price-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://gtspirit.com/2021/04/14/mclaren-artura-official-performance-figures-0-100km-h-%c2%bc-mile-top-speed/" rel="bookmark" title="McLaren Artura Performance Figures [0-100km/h, ¼ mile, Top Speed]">McLaren Artura Performance Figures [0-100km/h, ¼ mile, Top Speed]</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://gtspirit.com/2021/04/12/doesnt-get-more-greenier-rimac-unveils-new-hq-with-gardens-and-animal-farm/" rel="bookmark" class="td-image-wrap " title="Doesn&#8217;t Get Greenier than This: Rimac Unveils New HQ with Gardens and Animal Farm"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Doesn&#8217;t Get Greenier than This: Rimac Unveils New HQ with Gardens and Animal Farm" data-type="image_tag" data-img-url="https://gtspirit.com/wp-content/uploads/2021/04/Rimac-HQ-6-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://gtspirit.com/2021/04/12/doesnt-get-more-greenier-rimac-unveils-new-hq-with-gardens-and-animal-farm/" rel="bookmark" title="Doesn&#8217;t Get Greenier than This: Rimac Unveils New HQ with Gardens and Animal Farm">Doesn&#8217;t Get Greenier than This: Rimac Unveils New HQ with Gardens and Animal Farm</a></h3> </div>
</div>
</div> </div>
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://gtspirit.com/2021/04/10/mg-cyberster-uk-car-maker-reveals-full-electric-supercar/" rel="bookmark" class="td-image-wrap " title="MG Cyberster: UK Car Maker Reveals Full Electric Supercar"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="MG Cyberster price" title="MG Cyberster: UK Car Maker Reveals Full Electric Supercar" data-type="image_tag" data-img-url="https://gtspirit.com/wp-content/uploads/2021/04/MG-Cyberster-price-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://gtspirit.com/2021/04/10/mg-cyberster-uk-car-maker-reveals-full-electric-supercar/" rel="bookmark" title="MG Cyberster: UK Car Maker Reveals Full Electric Supercar">MG Cyberster: UK Car Maker Reveals Full Electric Supercar</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://gtspirit.com/2021/04/09/2020-audi-r8-rear-wheel-drive-review/" rel="bookmark" class="td-image-wrap " title="2020 Audi R8 Rear Wheel Drive Review"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="2020 Audi R8 Rear Wheel Drive Review" data-type="image_tag" data-img-url="https://gtspirit.com/wp-content/uploads/2021/04/ZaidH-Audi-R8RWD-2-218x150.jpg" width="218" height="150" /></a></div>  </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://gtspirit.com/2021/04/09/2020-audi-r8-rear-wheel-drive-review/" rel="bookmark" title="2020 Audi R8 Rear Wheel Drive Review">2020 Audi R8 Rear Wheel Drive Review</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://gtspirit.com/2021/04/09/bentley-mulliner-reveals-one-off-viridian-bentayga-for-chinese-customer/" rel="bookmark" class="td-image-wrap " title="Bentley Mulliner Reveals One-Off Viridian Bentayga for Chinese Customer"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Bentley Bentayga Hybrid" title="Bentley Mulliner Reveals One-Off Viridian Bentayga for Chinese Customer" data-type="image_tag" data-img-url="https://gtspirit.com/wp-content/uploads/2021/04/Bentley-Bentayga-Hybrid-218x150.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://gtspirit.com/2021/04/09/bentley-mulliner-reveals-one-off-viridian-bentayga-for-chinese-customer/" rel="bookmark" title="Bentley Mulliner Reveals One-Off Viridian Bentayga for Chinese Customer">Bentley Mulliner Reveals One-Off Viridian Bentayga for Chinese Customer</a></h3> </div>
</div>
</div> </div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_4_8dc" data-td_block_id="tdi_4_8dc"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-tdi_4_8dc" data-td_block_id="tdi_4_8dc"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> 
<div class="comments" id="comments">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/04/19/new-s-class-has-a-brabus-package-already-s500-now-produces-500hp/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://gtspirit.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><div class="clearfix"></div>
<div class="comment-form-input-wrap td-form-comment">
<textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
<div class="td-warning-comment">Please enter your comment!</div>
</div>
<div class="comment-form-input-wrap td-form-author">
<input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30" aria-required='true' />
<div class="td-warning-author">Please enter your name here</div>
</div>
<div class="comment-form-input-wrap td-form-email">
<input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30" aria-required='true' />
<div class="td-warning-email-error">You have entered an incorrect email address!</div>
<div class="td-warning-email">Please enter your email address here</div>
</div>
<div class="comment-form-input-wrap td-form-url">
<input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" />
</div>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='252269' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form> </div>
</div> 
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<div class="td_block_wrap td_block_social_counter td_block_widget tdi_7_d91 td-social-style10 td-social-boxed td-social-colored td-pb-border-top td_block_template_2"><div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">CONNECT WITH US</span></h4></div><div class="td-social-list"><div class="td_social_type td-pb-margin-side td_social_facebook"><div class="td-social-box"><div class="td-sp td-sp-facebook"></div><span class="td_social_info td_social_info_counter">486,305</span><span class="td_social_info td_social_info_name">Fans</span><span class="td_social_button"><a href="https://www.facebook.com/gtspirit" target="_blank">Like</a></span></div></div><div class="td_social_type td-pb-margin-side td_social_instagram"><div class="td-social-box"><div class="td-sp td-sp-instagram"></div><span class="td_social_info td_social_info_counter">577,196</span><span class="td_social_info td_social_info_name">Followers</span><span class="td_social_button"><a href="https://instagram.com/gtspirit#" target="_blank">Follow</a></span></div></div><div class="td_social_type td-pb-margin-side td_social_rss"><div class="td-social-box"><div class="td-sp td-sp-rss"></div><span class="td_social_info td_social_info_counter">203,128</span><span class="td_social_info td_social_info_name">Followers</span><span class="td_social_button"><a href="https://gtspirit.com/feed/" target="_blank">Follow</a></span></div></div><div class="td_social_type td-pb-margin-side td_social_twitter"><div class="td-social-box"><div class="td-sp td-sp-twitter"></div><span class="td_social_info td_social_info_counter">17,498</span><span class="td_social_info td_social_info_name">Followers</span><span class="td_social_button"><a href="https://twitter.com/gtspirit" target="_blank">Follow</a></span></div></div></div></div> <div class="td-a-rec td-a-rec-id-sidebar  tdi_8_670 td_block_template_2">
<style>
/* custom css */
.tdi_8_670.td-a-rec{
					text-align: center;
				}.tdi_8_670 .td-element-style{
					z-index: -1;
				}.tdi_8_670.td-a-rec-img{
				    text-align: left;
				}.tdi_8_670.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_8_670.td-a-rec-img {
				        text-align: center;
				    }
                }
</style>
<div id='div-gpt-ad-1587715863902-0'>
<script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1587715863902-0'); });
  </script>
</div></div><div class="td_block_wrap td_block_7 td_block_widget tdi_9_d9d td-pb-border-top td_block_template_2 td-column-1 td_block_padding" data-td-block-uid="tdi_9_d9d"><script>var block_tdi_9_d9d = new tdBlock();
block_tdi_9_d9d.id = "tdi_9_d9d";
block_tdi_9_d9d.atts = '{"custom_title":"LATEST ARTICLES","custom_url":"\/latest-articles\/","block_template_id":"","header_text_color":"#","limit":"5","offset":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_9_d9d","separator":"","m6_tl":"","show_modified_date":"","el_class":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"tdi_9_d9d","tdc_css_class_style":"tdi_9_d9d_rand_style"}';
block_tdi_9_d9d.td_column_number = "1";
block_tdi_9_d9d.block_type = "td_block_7";
block_tdi_9_d9d.post_count = "5";
block_tdi_9_d9d.found_posts = "38018";
block_tdi_9_d9d.header_color = "";
block_tdi_9_d9d.ajax_pagination_infinite_stop = "";
block_tdi_9_d9d.max_num_pages = "7604";
tdBlocksArray.push(block_tdi_9_d9d);
</script><div class="td-block-title-wrap"><h4 class="td-block-title"><a href="/latest-articles/" class="td-pulldown-size">LATEST ARTICLES</a></h4></div><div id=tdi_9_d9d class="td_block_inner">
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://gtspirit.com/2021/04/19/new-s-class-has-a-brabus-package-already-s500-now-produces-500hp/" rel="bookmark" class="td-image-wrap " title="New S-Class Has a Brabus Package Already &#8211; S500 Now Produces 500hp"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="Brabus S-Class hp" title="New S-Class Has a Brabus Package Already &#8211; S500 Now Produces 500hp" data-type="image_tag" data-img-url="https://gtspirit.com/wp-content/uploads/2021/04/Brabus-S-Class-hp-100x70.jpg" width="100" height="70" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://gtspirit.com/2021/04/19/new-s-class-has-a-brabus-package-already-s500-now-produces-500hp/" rel="bookmark" title="New S-Class Has a Brabus Package Already &#8211; S500 Now Produces 500hp">New S-Class Has a Brabus Package Already &#8211; S500 Now Produces...</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-19T15:48:16+02:00">19th April 2021</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://gtspirit.com/2021/04/17/audi-q4-e-tron-and-q4-sportback-e-tron-full-electric-suvs-join-e-tron-family/" rel="bookmark" class="td-image-wrap " title="Audi Q4 e-tron and Q4 Sportback e-tron: Full Electric SUVs Join e-tron Family"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="Audi Q4 50 e-tron vs Sportback" title="Audi Q4 e-tron and Q4 Sportback e-tron: Full Electric SUVs Join e-tron Family" data-type="image_tag" data-img-url="https://gtspirit.com/wp-content/uploads/2021/04/A211730_medium-100x70.jpg" width="100" height="70" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://gtspirit.com/2021/04/17/audi-q4-e-tron-and-q4-sportback-e-tron-full-electric-suvs-join-e-tron-family/" rel="bookmark" title="Audi Q4 e-tron and Q4 Sportback e-tron: Full Electric SUVs Join e-tron Family">Audi Q4 e-tron and Q4 Sportback e-tron: Full Electric SUVs Join...</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-17T18:34:42+02:00">17th April 2021</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://gtspirit.com/2021/04/16/2022-mercedes-benz-eqs-is-here-750hp-version-announced-too/" rel="bookmark" class="td-image-wrap " title="2022 Mercedes-Benz EQS is Here, 750hp Version Announced Too"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="Mercedes EQS 580 4Matic" title="2022 Mercedes-Benz EQS is Here, 750hp Version Announced Too" data-type="image_tag" data-img-url="https://gtspirit.com/wp-content/uploads/2021/04/20C0714_074-100x70.jpg" width="100" height="70" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://gtspirit.com/2021/04/16/2022-mercedes-benz-eqs-is-here-750hp-version-announced-too/" rel="bookmark" title="2022 Mercedes-Benz EQS is Here, 750hp Version Announced Too">2022 Mercedes-Benz EQS is Here, 750hp Version Announced Too</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-16T14:18:15+02:00">16th April 2021</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://gtspirit.com/2021/04/14/jaguar-f-type-r-dynamic-black-announced-with-fresh-updates/" rel="bookmark" class="td-image-wrap " title="2021 Jaguar F-Type R-Dynamic Black Announced with Fresh Updates"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="Jaguar F-Type P300 R-Dynamic" title="2021 Jaguar F-Type R-Dynamic Black Announced with Fresh Updates" data-type="image_tag" data-img-url="https://gtspirit.com/wp-content/uploads/2021/04/Jaguar-F-Type-P300-R-Dynamic-100x70.jpg" width="100" height="70" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://gtspirit.com/2021/04/14/jaguar-f-type-r-dynamic-black-announced-with-fresh-updates/" rel="bookmark" title="2021 Jaguar F-Type R-Dynamic Black Announced with Fresh Updates">2021 Jaguar F-Type R-Dynamic Black Announced with Fresh Updates</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-14T17:42:51+02:00">14th April 2021</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://gtspirit.com/2021/04/14/2022-nissan-gt-r-nismo-the-millionth-facelift-is-here/" rel="bookmark" class="td-image-wrap " title="2022 Nissan GT-R Nismo: the &#8216;Millionth Facelift&#8217; is Here"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="2022 Nissan GT-R Nismo" title="2022 Nissan GT-R Nismo: the &#8216;Millionth Facelift&#8217; is Here" data-type="image_tag" data-img-url="https://gtspirit.com/wp-content/uploads/2021/04/2022-Nissan-GT-R-Nismo-100x70.jpg" width="100" height="70" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://gtspirit.com/2021/04/14/2022-nissan-gt-r-nismo-the-millionth-facelift-is-here/" rel="bookmark" title="2022 Nissan GT-R Nismo: the &#8216;Millionth Facelift&#8217; is Here">2022 Nissan GT-R Nismo: the &#8216;Millionth Facelift&#8217; is Here</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-14T16:14:03+02:00">14th April 2021</time></span> </div>
</div>
</div>
</div> </div></div> <div class="td_block_wrap td_block_15 td_block_widget tdi_10_7d6 td-pb-border-top td_block_template_2 td-column-1 td_block_padding" data-td-block-uid="tdi_10_7d6"><script>var block_tdi_10_7d6 = new tdBlock();
block_tdi_10_7d6.id = "tdi_10_7d6";
block_tdi_10_7d6.atts = '{"custom_title":"LATEST FEATURES","custom_url":"\/category\/latest\/","block_template_id":"","header_text_color":"#","limit":"4","offset":"","post_ids":"","category_id":"27364","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget tdi_10_7d6","separator":"","mx4_tl":"","show_modified_date":"","el_class":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","mx4f_title_font_header":"","mx4f_title_font_title":"Article title","mx4f_title_font_settings":"","mx4f_title_font_family":"","mx4f_title_font_size":"","mx4f_title_font_line_height":"","mx4f_title_font_style":"","mx4f_title_font_weight":"","mx4f_title_font_transform":"","mx4f_title_font_spacing":"","mx4f_title_":"","mx4f_cat_font_title":"Article category tag","mx4f_cat_font_settings":"","mx4f_cat_font_family":"","mx4f_cat_font_size":"","mx4f_cat_font_line_height":"","mx4f_cat_font_style":"","mx4f_cat_font_weight":"","mx4f_cat_font_transform":"","mx4f_cat_font_spacing":"","mx4f_cat_":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"tdi_10_7d6","tdc_css_class_style":"tdi_10_7d6_rand_style"}';
block_tdi_10_7d6.td_column_number = "1";
block_tdi_10_7d6.block_type = "td_block_15";
block_tdi_10_7d6.post_count = "4";
block_tdi_10_7d6.found_posts = "921";
block_tdi_10_7d6.header_color = "";
block_tdi_10_7d6.ajax_pagination_infinite_stop = "";
block_tdi_10_7d6.max_num_pages = "231";
tdBlocksArray.push(block_tdi_10_7d6);
</script><div class="td-block-title-wrap"><h4 class="td-block-title"><a href="/category/latest/" class="td-pulldown-size">LATEST FEATURES</a></h4></div><div id=tdi_10_7d6 class="td_block_inner td-column-1"><div class="td-cust-row">
<div class="td-block-span12">
<div class="td_module_mx4 td_module_wrap td-animation-stack">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://gtspirit.com/2021/04/09/2020-audi-r8-rear-wheel-drive-review/" rel="bookmark" class="td-image-wrap " title="2020 Audi R8 Rear Wheel Drive Review"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="2020 Audi R8 Rear Wheel Drive Review" data-type="image_tag" data-img-url="https://gtspirit.com/wp-content/uploads/2021/04/ZaidH-Audi-R8RWD-2-218x150.jpg" width="218" height="150" /></a></div> </div>
<h3 class="entry-title td-module-title"><a href="https://gtspirit.com/2021/04/09/2020-audi-r8-rear-wheel-drive-review/" rel="bookmark" title="2020 Audi R8 Rear Wheel Drive Review">2020 Audi R8 Rear Wheel Drive Review</a></h3>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_mx4 td_module_wrap td-animation-stack">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://gtspirit.com/2021/04/08/5-cars-whose-prices-shot-up-like-bitcoin-since-2010/" rel="bookmark" class="td-image-wrap " title="5 Cars Whose Prices Shot Up Like Bitcoin Since 2010"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="GT-R R34" title="5 Cars Whose Prices Shot Up Like Bitcoin Since 2010" data-type="image_tag" data-img-url="https://gtspirit.com/wp-content/uploads/2021/04/GT-R-Z-Tune-218x150.jpg" width="218" height="150" /></a></div> </div>
<h3 class="entry-title td-module-title"><a href="https://gtspirit.com/2021/04/08/5-cars-whose-prices-shot-up-like-bitcoin-since-2010/" rel="bookmark" title="5 Cars Whose Prices Shot Up Like Bitcoin Since 2010">5 Cars Whose Prices Shot Up Like Bitcoin Since 2010</a></h3>
</div>
</div> </div><div class="td-cust-row">
<div class="td-block-span12">
<div class="td_module_mx4 td_module_wrap td-animation-stack">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://gtspirit.com/2021/03/26/modern-classics-ferrari-550-barchetta/" rel="bookmark" class="td-image-wrap " title="Modern Classics: Ferrari 550 Barchetta"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Modern Classics: Ferrari 550 Barchetta" data-type="image_tag" data-img-url="https://gtspirit.com/wp-content/uploads/2021/03/550-Barchetta-Girardo-6-218x150.jpg" width="218" height="150" /></a></div> </div>
<h3 class="entry-title td-module-title"><a href="https://gtspirit.com/2021/03/26/modern-classics-ferrari-550-barchetta/" rel="bookmark" title="Modern Classics: Ferrari 550 Barchetta">Modern Classics: Ferrari 550 Barchetta</a></h3>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_mx4 td_module_wrap td-animation-stack">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://gtspirit.com/2021/03/14/2022-bmw-m4-competition-review/" rel="bookmark" class="td-image-wrap " title="2022 BMW M4 Competition Review"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="2022 BMW M4 Competition Review" data-type="image_tag" data-img-url="https://gtspirit.com/wp-content/uploads/2021/03/BMW-M4-2021-13-218x150.jpg" width="218" height="150" /></a></div> </div>
<h3 class="entry-title td-module-title"><a href="https://gtspirit.com/2021/03/14/2022-bmw-m4-competition-review/" rel="bookmark" title="2022 BMW M4 Competition Review">2022 BMW M4 Competition Review</a></h3>
</div>
</div> </div></div></div> <div class="clearfix"></div><div class="td-a-rec td-a-rec-id-custom_ad_1  tdi_11_087 td_block_template_2">
<style>
/* custom css */
.tdi_11_087.td-a-rec{
					text-align: center;
				}.tdi_11_087 .td-element-style{
					z-index: -1;
				}.tdi_11_087.td-a-rec-img{
				    text-align: left;
				}.tdi_11_087.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_11_087.td-a-rec-img {
				        text-align: center;
				    }
                }
</style>
<div id='div-gpt-ad-1587716430373-0' style='width: 300px; height: 600px;'>
<script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1587716430373-0'); });
  </script>
</div></div> </div>
</div>
</div> 
</div> 
</article> 

<div class="tdc-footer-wrap ">


<div class="td-sub-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span td-sub-footer-menu">
<div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="td-subfooter-menu"><li id="menu-item-129290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-first td-menu-item td-normal-menu menu-item-129290"><a href="https://gtspirit.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-129291" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-129291"><a href="https://gtspirit.com/disclaimer/">Disclaimer</a></li>
<li id="menu-item-129292" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-129292"><a href="https://gtspirit.com/advertise/">Advertise</a></li>
<li id="menu-item-129294" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-129294"><a href="https://gtspirit.com/tips/">Tips</a></li>
<li id="menu-item-129293" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-129293"><a href="https://gtspirit.com/contact/">Contact</a></li>
</ul></div> </div>
<div class="td-pb-span td-sub-footer-copy">
&copy; Copyright GTspirit Limited 2005-2020 </div>
</div>
</div>
</div>
</div>
</div>

<script type="text/javascript">tb_pathToImage = "https://gtspirit.com/wp-includes/js/thickbox/loadingAnimation.gif";tb_closeImage = "https://gtspirit.com/wp-includes/js/thickbox/tb-close.png";</script>
<script type='text/javascript'>
/* <![CDATA[ */
var zerospam = {"key":"j!10n!nmtDQ6w2pz^bh&j#$z5XDEi1VZuAnik6M3Gh(FeS3OI0$5#I*Ex4nTA*py"};
/* ]]> */
</script>
<script type='text/javascript' src='https://gtspirit.com/wp-content/plugins/zero-spam/js/zerospam.js?ver=3.1.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/gtspirit.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://gtspirit.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript' src='https://gtspirit.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript' src='https://gtspirit.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=243b277d395aac11337949f2c0b8e89c'></script>
<script type='text/javascript' src='https://gtspirit.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.3.4'></script>
<script type='text/javascript' src='https://gtspirit.com/wp-includes/js/comment-reply.min.js?ver=5.4.5'></script>
<script type='text/javascript' src='https://gtspirit.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=243b277d395aac11337949f2c0b8e89c'></script>
<script type='text/javascript' src='https://gtspirit.com/wp-includes/js/wp-embed.min.js?ver=5.4.5'></script>

<script>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</script>
</body>
</html>

